Acomba (Forum)
Pourquoi ne pas devenir membre du forum ?

Identifiez-vous ou Inscrivez-vous afin d'accéder à l'inrégralité du forum:
Accès à toutes les catégories du forum,
Entraide entre les 6 500 membres, et ce nombre s'accroît quotidiennement!

Notez que ce forum est indépendant de la société Acceo Solutions, éditrice du logiciel Acomba.
Connexion

Récupérer mon mot de passe


Connexion ODBC - Compagnie sur un lecteur réseau

Voir le sujet précédent Voir le sujet suivant Aller en bas

Connexion ODBC - Compagnie sur un lecteur réseau

Message  anis797979 le Lun 30 Juin 2008 - 17:34

Bonjour,

Il nous est impossible de nous connecter à la source de données ODBC
d'Acomba si le dossier de la compagnie se trouve sur un lecteur réseau.
Tout marche parfaitement si le dossier de la compagnie se trouve sur le
disque local.

L'erreur que nous avons est la suivante:

Dossier de compagnie invalide. (Z:\xxx).

Notez aussi que nous pouvons nous connecter à la compagnie (sur le
lecteur réseau) depuis Acomba (pas ODBC).

D'ailleurs, quand on fait "Tester la connexion" dans les sources de données ODBC avec la compgnie sur le lecteur réseau, ça dit que la connexion s'effectue avec succès...

Nous utilisons Apache/PHP. Tout fonctionne parfaitement quand les données de la compagnie sont en local.

Pourriez-vous nous aider? Merci d'avance!

Cordialement,

Anis

anis797979

Nombre de messages : 1
Date d'inscription : 30/06/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

ODBC en réseau

Message  Lartis le Mar 1 Juil 2008 - 0:24

Bonjour,

J'ai plusieurs projets qui utilisent ODBC par un lecteur réseau, et je n'ai jamais eu ce problème. Par contre, aucun de ces projets n'est en PHP.

Essayer de voir si un fichier Access arrive à accéder aux données par ODBC à partir du même poste. Si oui, le problème est dans ce cas spécifique à PHP. Si non, le problème est au niveau d'ODBC, mais puisque "tester la connexion" fonctionne, je suis pas mal certain que ça va marcher.

Vous pourriez essayer un path UNC à la place du lecteur réseau (\\nom_du_serveur\disque\répertoire). Ça pourrait régler le problème.

Il se peut aussi que ce soit un problème de droits d'accès. Assurez-vous que l'usager Windows qu'utilise PHP pour se connecter au réseau a les droits suffisant dans les répertoires concernés.

Bonne chance!

_________________
Sylvain Laurence, partenaire, revendeur et développeur Acomba
Groupe Conseil Lartis Inc. www.lartis.com
avatar
Lartis

Nombre de messages : 640
Ville : Laval
Date d'inscription : 03/04/2007

Fiche d'Entreprise
Nom de l'entreprise: Groupe Conseil Lartis Inc.

Voir le profil de l'utilisateur http://www.lartis.com

Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum